Back to overview
Downtime

Cloudflare experiences global outage

Nov 18, 2025 at 11:37am UTC
Affected services
Cloudflare Services

Resolved
Nov 18, 2025 at 03:30pm UTC

Websites back online after global Cloudflare outage.

Created
Nov 18, 2025 at 11:37am UTC

Cloudflare is currently experiencing an outage. Websites using Cloudflare will experience intermittent downtime.